Logowanie Google+ Logowanie Rejestracja

Poszukujemy moderatorów, nie czekaj, złóż podanie już teraz: KLIK

Problem z siewnikiem
#1
Witam mam problem otóż przekonwertowałem siewnik konny ale coś nie działa, ponieważ wyskakuje taki błąd:

Error: C:/Users/Admin/Documents/My Games/FarmingSimulator2017/mods/Siewnik/SiewnikKonny.xml. vehicle. .

Error: No storeData found in 'C:/Users/Admin/Documents/My Games/FarmingSimulator2017/mods/Siewnik/SiewnikKonny.xml'. StoreItem will be ignored!


Xml tego modu:

<?xml version="1.0" encoding="utf-8" standalone="no" ?>
<vehicle type="sowingMachine">
    <annotation>Copyright © GIANTS Software GmbH, All Rights Reserved.</annotation>

    <storeData>
        <name>Siewnik Konny</name>
        <specs>
            <neededPower>25</neededPower>
            <workingWidth>4.0</workingWidth>
        </specs>
        <functions>
            <function>$l10n_function_sowingMachine</function>
        </functions>
        <image>data/store/store_kvernelandAccordDL.png</image>
        <price>5000</price>
        <dailyUpkeep>5</dailyUpkeep>
        <lifetime>600</lifetime>
        <rotation>0</rotation>
        <brand>KVERNELAND</brand>
        <category>sowingMachines</category>
        <fieldJob sizeCategory="1" typeCategory="sowingMachine" />
        <vertexBufferMemoryUsage>1547436</vertexBufferMemoryUsage>
        <indexBufferMemoryUsage>234516</indexBufferMemoryUsage>
        <textureMemoryUsage>10660680</textureMemoryUsage>
        <instanceVertexBufferMemoryUsage>0</instanceVertexBufferMemoryUsage>
        <instanceIndexBufferMemoryUsage>0</instanceIndexBufferMemoryUsage>
    </storeData>

    <typeDesc>$l10n_typeDesc_sowingMachine</typeDesc>
    <filename>SiewnikKonny.i3d</filename>

    <size width="3.5" length="2.5"/>
    <speedLimit value="15" />

    <brakeForce>0.8</brakeForce>

    <wheelConfigurations>
        <wheelConfiguration name="$l10n_configuration_valueDefault" price="0">
            <wheels>
                <wheel restLoad="0.6" repr="0>3|0|0" linkNode="0>0|6|0|0" forcePointRatio="0.2" filename="$data/vehicles/wheels/trelleborg/IM110_7_00_12.xml" isLeft="false" initialCompression="20" suspTravel="0.05" spring="45" damper="50" rotationDamping="0.002" />
                <wheel restLoad="0.6" repr="0>3|1|0" linkNode="0>0|6|1|0" forcePointRatio="0.2" filename="$data/vehicles/wheels/trelleborg/IM110_7_00_12.xml" isLeft="true"  initialCompression="20" suspTravel="0.05" spring="45" damper="50" rotationDamping="0.002" />
            </wheels>
        </wheelConfiguration>
    </wheelConfigurations>

    <workAreas>
        <workArea startIndex="0>4|0" widthIndex="0>4|1" heightIndex="0>4|2" refNodeIndex="0" type="sowingMachine" />
    </workAreas>

    <groundReferenceNodes>
        <groundReferenceNode index="0>"      threshold="0.1" depthNode="0>5|1"/>
    </groundReferenceNodes>

    <sowingSound file="$data/sounds/sowingSound.wav"      pitchOffset="1.0" volume="1.0" indoorVolumeFactor="0.55" />
    <airBlowerSound file="$data/sounds/airBlowerLoop.wav" pitchOffset="1.2" volume="1.0" indoorVolumeFactor="0.55" />
    <fillSound file="$data/maps/sounds/siloFillSound.wav" pitchOffset="1.0" volume="1.0" indoorVolumeFactor="0.55" volume3D="1.0" innerRadius="10" radius="40" linkNode="0>0"/>
    <cylinderedHydraulicSound file="$data/sounds/cultivatorHydraulic.wav" pitchOffset="1.00" volume="1.00" indoorVolumeFactor="0.75" />

    <inputAttacherJoints>
        <inputAttacherJoint index="0>6" jointType="implement" lowerDistanceToGround="0.56" upperDistanceToGround="2.5" topReferenceNode="0>7" />
    </inputAttacherJoints>

        <groundParticle>
            <node index="0>5|0|0" refNodeIndex="0" particleType="SOIL"  />
            <node index="0>5|0|1" refNodeIndex="0" particleType="SOIL_SMOKE"  />
            <node index="0>5|0|2" refNodeIndex="0" particleType="SOIL_CHUNKS" worldSpace="false"/>
        </groundParticle>
    </groundParticleAnimations>

    <wheelConfigurations>
        <wheelConfiguration name="$l10n_configuration_valueDefault" price="0">
            <wheels>
                <wheel restLoad="0.6" repr="0>8|0" linkNode="0>8|0|0" forcePointRatio="0.2" filename="$data/vehicles/wheels/trelleborg/IM110_7_00_12.xml" isLeft="false" initialCompression="20" suspTravel="0.05" spring="45" damper="50" rotationDamping="0.002" />
                <wheel restLoad="0.6" repr="0>8|1" linkNode="0>8|1|0" forcePointRatio="0.2" filename="$data/vehicles/wheels/trelleborg/IM110_7_00_12.xml" isLeft="true"  initialCompression="20" suspTravel="0.05" spring="45" damper="50" rotationDamping="0.002" />
            </wheels>
        </wheelConfiguration>
    </wheelConfigurations>

    <fillUnits>
        <fillUnit unit="$l10n_unit_literShort" fillTypes="seeds" capacity="750" />
    </fillUnits>

    <needsActivation value="true" />
    <fillLitersPerSecond>100</fillLitersPerSecond>
    <seedFruitTypeCategories>sowingMachine</seedFruitTypeCategories>

    <fillVolumes>
        <volumes>
            <volume index="0>9|0" maxDelta="0.2" />
        </volumes>
        <unloadInfos>
            <unloadInfo>
                <node index="0>9|1" width="1.4" length="0.1" />
            </unloadInfo>
        </unloadInfos>
        <loadInfos>
            <loadInfo>
                <node index="0>9|2" width="1.4" length="0.1" />
            </loadInfo>
        </loadInfos>
    </fillVolumes>

    <washable dirtDuration="60" washDuration="1" workMultiplier="20" />

    <ai>
        <areaMarkers leftIndex="0>10|0|0" rightIndex="0>10|0|1" backIndex="0>10|0|2" />
    </ai>

    <components count="1">
        <component1 centerOfMass="0 0 0" solverIterationCount="10" />
    </components>

    <schemaOverlay file="$dataS2/menu/schemas/implementSchema.png" fileSelected="$dataS2/menu/schemas/implementSchemaSelected.png" fileTurnedOn="$dataS2/menu/schemas/implementSchemaTurnedOn.png" fileSelectedTurnedOn="$dataS2/menu/schemas/implementSchemaSelectedTurnedOn.png" width="0.5" height="0.5" attacherJointPosition="0 0"/>

</vehicle>

Moddesc:

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<modDesc descVersion="32">
    <author>9michael6 FS15: RomeG Dirt: _3p</author>
    <version>1.0</version>
    <title>
        <en>Siewnik konny.</en>
        <de>Siewnik konny.</de>
    </title>
    <description>
        <en>Siewnik konny przerobiony do ciagnika.
</en>
        <de>Siewnik konny przerobiony do ciagnika.
</de>
    </description>
    <iconFilename>store.png</iconFilename>
    <multiplayer supported="true"/>
    
    <type name="sowingMachine" className="Vehicle" filename="dataS/scripts/vehicles/Vehicle.lua">
        <specialization name="attacherJoints" />
        <specialization name="lights" />
        <specialization name="workArea" />
        <specialization name="workParticles" />
        <specialization name="speedRotatingParts" />
        <specialization name="attachable" />
        <specialization name="turnOnVehicle" />
        <specialization name="powerConsumer" />
        <specialization name="animatedVehicle" />
        <specialization name="cylindered" />
        <specialization name="fillable" />
        <specialization name="fillVolume" />
        <specialization name="sowingMachine" />
        <specialization name="foldable" />
        <specialization name="ridgeMarker" />
        <specialization name="cover" />
        <specialization name="washable" />
        <specialization name="mountable" />
    </type>

<storeItems>
        <storeItem xmlFilename="SiewnikKonny.xml"/>
    </storeItems>

</modDesc>
 
Taka tam sobie reklama.
#2
Prawdopobnie masz błąd w składni w xml. Przejrzyj go całego dokładnie. Najlepiej to będzie widać w notepad++, jeśli go jeszcze nie masz to polecam z niego korzystać.
No to jedziemy, gnębić podpadziochów!
 
#3
(08-04-2018, 11:48)agRush2k napisał(a): Prawdopobnie masz błąd w składni w xml. Przejrzyj go całego dokładnie. Najlepiej to będzie widać w notepad++, jeśli go jeszcze nie masz to polecam z niego korzystać.

Dobra naprawiłem to ale możesz mi jeszcze powiedzieć co zmienić, ponieważ gdy kupuje go to przewraca się do tyłu
 
#4
Spróbuj z ustawieniem środka ciężkości (centerOfMass) w pierwszej linijce pod znacznikiem <components>
No to jedziemy, gnębić podpadziochów!
 
#5
(08-04-2018, 17:13)agRush2k napisał(a): Spróbuj z ustawieniem środka ciężkości (centerOfMass) w pierwszej linijce pod znacznikiem <components>

Dobra już wiem ale teraz jes jeszcze 1 problem
Gdy chcę siać to ten siewnik podskakuje bo jest ustawiona kolizja tylko ona jest tak ustawiona że jest jako najgłówniejszy plik z całym modelem i jak to teraz zrobić aby usunąć tą kolizję bo próbuje ale mi cała gra się ścina
 
#6
Chodzi mi o to:
https://abload.de/img/gt3fq3.png
https://abload.de/img/fsscreen_2018_08_04_2ymekv.png
https://abload.de/img/fsscreen_2018_08_04_21hc1z.png
Model podczas jazdy z opuszczonym podskakuje przez tą kolizje
 
Taka tam sobie reklama.
#7
A jak to wygląda jak ten siewnik jest podczepiony do podstawowej maszyny, ten łącznik górny podskakuje? Jeśli tak to do linijki z <inputAttacherJoint dodaj atrybut fixedRotation="true".
No to jedziemy, gnębić podpadziochów!
 
#8
On tak jakby ten górny zaczep się całkowicie chował po opuszczeniu
https://abload.de/img/fsscreen_2018_08_04_2nsivu.png

Poczekaj bo jak dodałem to przestało podskakiwać ale jeszcze muszę coś sprawdzić odpiszę jak mi się uda

Dobra dzięki gościu pomogłeś mi naprawić ten błąd masz +1 ode mnie Smile
 
  


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Problem Smoke WeeD 12 574 10-12-2018, 22:37
Ostatni post: Smoke WeeD
  BallyMoon Castle - problem TMR wiisixtythreePL 1 185 10-06-2018, 02:02
Ostatni post: Szydar
  problem z follow me kurde912 1 538 10-04-2018, 22:20
Ostatni post: TwinTurbo
  Problem z włączeniem gry. damianbogdan 6 281 10-03-2018, 18:00
Ostatni post: Robetr Żebrowski
  Problem z okrągłymi belami rockybalbao99 3 150 10-01-2018, 13:46
Ostatni post: FresZu44
  Problem z modami TheNextPl 123 4 520 09-26-2018, 09:34
Ostatni post: Ziuta
  problem z modem Michal Stepak 12 496 09-20-2018, 23:24
Ostatni post: Michal Stepak
  Problem z mapą Paw3ll 4 393 09-18-2018, 02:28
Ostatni post: Szydar
  Problem z mapa Bizon666 0 140 09-15-2018, 11:00
Ostatni post: Bizon666
  problem z paszowozem 8MG 0 131 09-15-2018, 09:10
Ostatni post: 8MG



Przegląda: 1 gości

Menu