Logowanie Google+ Logowanie Rejestracja

Poszukujemy moderatorów, nie czekaj, złóż podanie już teraz: KLIK

Problem z animacja sieczki
#1
Witam, chciałem przenieśc animacje promieniową sieczki z lexiona 8900 z dodatku claas.   i niby sie udalo ale nie dokonca. bo efekt jest taki ze model sieczki przybiera kształt taki jak powinien ale nie ma animacji ruchu od lewa do prawa itd.  Wydaje mi sie ze napisałem to dobrze ale dla jasności wrzucam tutaj skrypt.
Animacja:
<animation name="Sieczkarnia" looping="true">
            <part node="0>18|0|0|0|4|0" startTime="0" endTime="20"  startRot="0 -20 0"  endRot="0 20 0" />
            <part node="0>18|0|0|0|4|0" startTime="20" endTime="0"  startRot="0 20 0" endRot="0 -20 0" />
           <part node="0>18|0|0|0|4|1" startTime="0" endTime="20"  startRot="0 20 0"  endRot="0 -20 0" />
            <part node="0>18|0|0|0|4|1" startTime="20" endTime="0"  startRot="0 -20 0" endRot="0 20 0" />
        </animation>

A tutaj sama sieczka:
        <chopperEffect>
              <effectNode effectClass="SlurrySideToSideEffect" effectNode="0>18|0|0|0|4|0" materialType="chopper" materialTypeId="2" delay="0" refAnimation="Sieczkarnia" offset="0.5"/>
            <effectNode effectClass="SlurrySideToSideEffect" effectNode="0>18|0|0|0|4|1" materialType="chopper" materialTypeId="2" delay="0" refAnimation="Sieczkarnia"/>
            <effectNode effectNode="0>20|1" materialType="chopper" materialTypeId="1" delay="0"/>
            <effectNode effectNode="0>18|0|0|0|4|2" effectClass="ParticleEffect" particleType="smoke"/>
            <effectNode effectNode="0>18|0|0|0|4|3" effectClass="ParticleEffect" particleType="smoke"/>
            <effectNode effectNode="0>8|1|3" effectClass="ParticleEffect" particleType="smoke"/>
            <effectNode  effectNode="0>8|1|4" effectClass="ParticleEffect" particleType="smoke"/>
        </chopperEffect>

Błędów ządnych w logu nie ma wiec jest ok tylko animacja ruchu sie nie odpala.


EDIT: Rozwiazałem problem i sieczka działa.  Nie zauwazylem jednego skryptu potrzebnego do działania:
<turnOnVehicle turnOffIfNotAllowed="true" >
        <turnedOnAnimation name="Sieczkarnia" turnOffFadeTime="10"/>
    </turnOnVehicle>
 
Odpowiedz
Taka tam sobie reklama.
  


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Problem z koszeniem trawy googlownik 0 14 2 godzin(y) temu
Ostatni post: googlownik
  Problem ze sprzedażą jaj Minkmink 0 47 Wczoraj, 22:58
Ostatni post: Minkmink
  Problem ze Pracownikiem jenot12312 2 278 09-13-2020, 19:10
Ostatni post: jenot12312
  Problem z napełnianiem kbostroda 1 228 09-07-2020, 14:41
Ostatni post: Darecki30
  Problem z uruchomieniem gry jagiellmen 2 310 09-06-2020, 11:19
Ostatni post: janekski
  Problem z zapisem gry Rugasz 0 265 08-31-2020, 11:25
Ostatni post: Rugasz
  Problem na multiplayer slaXooo 0 276 08-30-2020, 22:02
Ostatni post: slaXooo
  Problem z animacjami w budynku placeable ShizeR 0 209 08-29-2020, 23:13
Ostatni post: ShizeR
  Problem z systemem pasów Kacper0345 0 183 08-27-2020, 11:52
Ostatni post: Kacper0345
  Problem z kierownicą Tracer Drifter FS19 kamil88 1 373 08-24-2020, 08:52
Ostatni post: pawelek_n



Przegląda: 1 gości

Menu